This project has moved. For the latest updates, please go here.

[Resolved] "An error has occured" - when trying to remove faulty feature

Sep 18, 2013 at 8:28 AM
Edited Sep 18, 2013 at 9:22 AM
Hey Guys,

I'm running the tool as a farm admin. My account has also full access to SQL and is domain admin. Just to be sure, I gave my account Full Control via the User Policy on all webapps. I've tried running FeatureAdmin as normal or as admin.

FeatureAdmin does detect some faulty features in the farm :

Image

But if I click Yes to removethe feature I get the following error :

Image

Nothing is removed. If I run the Find Faulty Feature in Farm it finds the same faulty features again.

I tried to lookup more info about these features but of course nothing is displayed since these ae not installed on the farm.
Get-SPFeature | ? {$_.ID -like "ee18*"}
Gave no result.

What can I do to work around this issue ?

Thanks
Coordinator
Oct 18, 2013 at 3:32 PM
Edited Oct 18, 2013 at 3:33 PM
Here is a web page with some common sense tips for bug reports and help requests (I decided to save myself the work of typing them over and over, because a surprising number of people omit even the most basic version information):

https://charts4sharepoint.codeplex.com/wikipage?title=Reporting%20Bugs%20for%20SharePoint%20Projects
Dec 2, 2013 at 1:23 PM
I have the same problem. Are you using SharePoint 2013 in 2010 compatibility mode?

I can delete faulty features at a Site Collection level, but not for a farm or web app.

Laurence
Coordinator
Aug 27, 2015 at 5:59 PM
The above bug reports lack any version info, so it is difficult to help them.

But for anyone else who sees this, consider trying the new 2.4 release.
Sep 21, 2015 at 10:37 AM
I'm using latest version (2.4.2.0) in SharePoint 2013 and I'm getting that same error when "Find Faulty Feature in Farm" founds the first site collection scoped error feature. The error pops up when it starts to go through the first web application in the list, which in current customer's case is Apps Host web application.

It seems however that removing SPWeb scoped features from whole farm with that button works fine (even though that log just spits error "Object reference not set to an instance of an object." for webs where error feature wasn't found).

I checked that the account I'm using has necessary permissions in SQL and web applications.
Coordinator
Sep 22, 2015 at 7:04 PM
What error are you getting?
Sep 23, 2015 at 6:16 AM
PerrySharePoint wrote:
What error are you getting?
Like I said, the same error as shown on screenshots above.
Coordinator
Sep 23, 2015 at 2:25 PM
How similar is your error to that one? Is every character and byte identical, or is it just similar, and if so, how does it differ?

(This kind of slow and tedious back and forth trying to get the error message from the user, is the reason a lot of project and support staff just do not accept or handle bug reports until all the information is filled in. The problem is that the developer cannot see what the user sees, until the user copies & pastes it to show, and often users are reluctant to do so, for whatever reason.. and this leads to projects, developers, and support staff becoming reluctant to deal with bug reports.)

In the meantime, even lacking your actual error details, I took a guess, and made a release.
Sep 23, 2015 at 3:42 PM
Yeah sorry about that. I understand completely the frustration of shady bug reports as I have to do the same thing in my work as a developer.

At least first look of the error message seems the same. It's hard however to compare the error message as you can't copy paste the content from the dialog window. Here is my version of the error:
Image

I'll test you updated version next. And thanks for the quick response!
Sep 23, 2015 at 3:51 PM
Yeah now the error didn't stop the whole process so the issue is now resolved. I guess it was just adding some try/catch? :)

Thanks again for this great tool!
Coordinator
Sep 23, 2015 at 4:33 PM
Yes, you have nailed it -- just added a catch. Actually someone had posted a patch for that earlier this year, and then I posted a patch for it as well a day or two ago. Now the try/catch is in the trunk and in the release.

(I did not write the whole tool, I have just helped improve it, as I use it myself from time to time.)

Glad to hear that worked. Thanks for the quick feedback.
Marked as answer by PerrySharePoint on 2/18/2016 at 9:53 AM